Hasta ahora, cuando queríamos usar en Android 2.x algo semejante a la Action Bar introducida en Honeycomb, teníamos que usar la excelente (y hablo de oídas porque yo no he llegado a usarla) ActionBarSherlock. Sin embargo, la gente de Google han estado trabajando en la compatibilidad con versiones anteriores, lo cual no es de extrañar teniendo en cuenta el elevado porcentaje de Froyo que todavía circulan por ahí (a día de hoy, el mio después de mi downgrade xD).

El caso es que han sacado con la librería de soporte r18, una versión de la v7 con una appcompat library que nos permite usar ActionBar desde android 2.1, vamos, en el 99.9% de los dispositivos.

Cómo instalarla nos lo explica claramente Google en su web de Android developers, que podéis consultar aquí.

Una vez la tengamos operativa podremos realizar proyectos con ActionBarCompat para dispositivos antiguos. Para leer un poco más sobre ella y los cambios que introduce en nuestro código antiguo, podemos consultar aquí.

Anuncios